Do you support DUAL SIM phones?

Textra (from v3.23) supports dual sim devices for Android 5.1 and above.

Google only added support for dual sim devices in stock Android from Android 5.1.

So, prior to Android 5.1, there are no standard interfaces for dual sim devices. Each and every manufacturer of a dual sim device was required to modify stock Android to support their specific dual sim device. There are over 8,000 different dual sim devices.

Some other apps (like chompSMS) do provide limited dual sim functionality prior to Android 5.1 by implementing a specific manufacturer’s interface. The key issue with this approach (apart from being a massive task) is that it slows down the app and also increases the app install size significantly.

Apologies if you are running a version of Android prior to 5.1. However in line with our goal of ensuring Textra does not become bloated and remains super fast, we have no plans to add support prior to Android 5.1.

Feedback and Knowledge Base